Multiple Web Servers on Mikrotik RouterOS

Multiple Web Servers on Mikrotik RouterOS
User Rating: 0 (0 votes)

Catatan : ini hanya bekerja pada koneksi yang menggunakan HTTP tidak koneksi HTTPS, transparent web proxy belum support untuk koneksi HTTPS. mikrotik menggunakan Router OS versi 6 ke atas

bayangkan, seandainya kita hanya memiliki 1 ip publik dengan contoh alamat xxx.xxx.xxx.xxx tapi ingin meng hostingkan 3 web server :

123.com@192.168.0.2
abc.com@192.168.0.3
456.com@192.168.0.4

Langkah-langkah sebagai berikut :

1. Konfigurasi web proxy di mikrotik sebagai berikut :

/ip proxy
set enabled=yes src-address=0.0.0.0 port=8080 parent-proxy=0.0.0.0:0 \
cache-administrator=”webmaster” max-object-size=4096KiB cache-drive=system \
max-cache-size=unlimited max-ram-cache-size=unlimited
/ip proxy access
add dst-port=23-25 action=deny comment=”block telnet & spam e-mail relaying” \
disabled=no
add dst-port=80 action=allow comment=”Enable Http Connection” disabled=no

2. Konfigurasi static DNS kepada domain yang akan di resolve ke IP internal

/ip dns static add name=123.com address=192.168.0.2
/ip dns static add name=abc.com address=192.168.0.3
/ip dns static add name=456.com address=192.168.0.4
/ip dns static add name=www.123.com address=192.168.0.2
/ip dns static add name=www.abc.com address=192.168.0.3
/ip dns static add name=www.456.com address=192.168.0.4

3. Konfigurasi NAT untuk men redirect trafik ke web proxy

/ip firewall nat
add chain=dstnat in-interface=outside dst-address=xxx.xxx.xxx.xxx protocol=tcp \
dst-port=80 action=redirect to-ports=8080 comment=”” disabled=no

Trafik ke 123.com akan seperti ini :

Web proxy akan men redirect trafik ke 123.com ke internal ip address di 192.168.0.2

Internet –> xxx.xxx.xxx.xxx:80 —> xxx.xxx.xxx.xxx:8080 –> 192.168.0.2:80

Terakhir..

Jangan lupa untuk membatasi akses url ke proxy Anda, jika router Anda dapat digunakan untuk mengarahkan lalu lintas ke situs luar jaringan Anda

/ip proxy access
add dst-port=80 dst-host=”123.com” action=allow disabled=no
add dst-port=80 dst-host=”abc.com” action=allow disabled=no
add dst-port=80 dst-host=”456.com” action=allow disabled=no
add action=deny disabled=no

 

Semoga ini membantu

sumber : wiki.mikrotik.com

3 Comments

  1. Fabulous, what a weblog it is! This weblog gives valuable
    information to us, keep it up.

  2. Your way of explaining all in this paragraph is genuinely fastidious, all
    be capable of simply understand it, Thanks a lot.

  3. Hi there all, here every one іѕ sharing these know-hoѡ, therefore it’s
    good to read this blog, and I used tօ visіt this weblog daily.

Leave a Reply

Your email address will not be published. Required fields are marked *

*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>